United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Oklahoma DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jan 06, 2023 - 18:51 UTC
Identified
The Oklahoma DMV will be performing scheduled maintenance today from 6-9pm PT. MVRs requested during this time will not be completed until the scheduled maintenance is done.
Posted Jan 05, 2023 - 17:08 UTC