United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Florida DMV Maintenance 5/20 - 5/23 **Corrected Dates**
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted May 24, 2022 - 19:01 UTC
Update
The scheduled maintenance window is for this Friday, May 20 through Monday, May 23. Apologies for the confusion.
Posted May 20, 2022 - 03:56 UTC
Update
Reminder: Florida MVRs will be unavailable beginning on Friday evening, May 20 with service expected to be restored on Monday morning, May 23.
Posted May 20, 2022 - 03:25 UTC
Identified
The Florida DMV will be offline for maintenance beginning Friday evening, May 20. Service is expected to be restored on Monday morning, May 23. Florida MVRs that are ordered during this window will complete once maintenance is completed and service is restored.
Posted May 16, 2022 - 18:20 UTC