United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Louisiana and Mississippi Courts Closed due to Hurricane
Incident Report for Checkr US Data Status
Resolved
09/10/2021: The majority of the courts in Louisiana and Mississippi have reopened post-Hurricane Ida. The only courts still CLOSED are: Wilkinson, MS & St. James, St. Helena, and Livingston, LA.
Posted Sep 10, 2021 - 20:12 UTC
Update
09/08/2021: Some courts still remain closed in Louisiana and Mississippi. Additional county courts have reopened:

Re-opened Counties:
Louisiana - St. John the Baptist & Natchitoches
ALREADY OPEN: Acadia, Allen, Beauregard, Cameron, Evangeline, Iberia, Jefferson Davis, St. Landry, Tensas, & Union
Mississippi - Pike & Jackson
ALREADY OPEN: Forrest, Green, Hancock, Harrison, & Itawamba
Posted Sep 08, 2021 - 20:06 UTC
Monitoring
09/02/2021: Some courts in Louisiana and Mississippi remain closed post-Hurricane Ida. The list of courts that have reopened is below; please expect some delays as researchers complete searches.

Re-opened Counties:
Louisiana - Acadia, Allen, Beauregard, Cameron, Evangeline, Iberia, Jefferson Davis, St. Landry, Tensas, & Union
Mississippi - Forrest, Green, Hancock, Harrison, & Itawamba
Posted Sep 02, 2021 - 16:10 UTC
Update
We are continuing to work on a fix for this issue.
Posted Aug 30, 2021 - 17:51 UTC
Identified
08/30/2021: The majority of Louisiana Courts are closed due to Hurricane Ida. There is currently no ETA of when these will reopen, but we will keep in contact with the courts and notify you of any changes.
Posted Aug 30, 2021 - 17:39 UTC