United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Nevada DMV is Offline
Incident Report for Checkr US Data Status
Resolved
1/12/2022: The Nevada DMV is back online.
Posted Jan 12, 2022 - 16:35 UTC
Monitoring
1/11/2022: The Nevada online DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will update as we learn more.
Posted Jan 11, 2022 - 17:19 UTC