United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Hurricane Ian - Possible Delays and Closures
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Sep 30, 2022 - 17:16 UTC
Update
09/29/2022: Courts across Florida and Georgia are affected due to Hurricane Ian.

*All searches affected, no searches will be completed:
FL - MANATTE ; no ETA of reopening
GA - LONG, WAYNE ; ETA of reopening is 9.30.2022

*Only a very small number of searches that require in-court research will be affected:
FL - ALACHUA, BAKER, BAY, BRADFORD, BREVARD, BROWARD, CHARLOTTE, CITRUS, CLAY, COLLIER, DE SOTO, DUVAL, FLAGER, GILCHRIST, GLADES, HARDEE, HENDRY, HERNANDO, HIGHLANDS, HILLSBOROUGH, INDIAN RIVER, LAKE, LEE, LEVY, MARION, MARTIN, MIAMI DADE, MONROE, NASSAU, OKECHOBEE, ORANGE, OSCEOLA, PALM BEACH, PASCO, PINELLAS, POLK, PUTNAM, SAINT JOHNS, SAINT LUCIE, SARASOTA, SEMINOLE, SUMTER, UNION, and VOLUSIA
GA - LIBERTY
Posted Sep 29, 2022 - 15:58 UTC
Monitoring
09/28/2022: We are continuing to monitor any courts that might be affected by Hurricane Ian, but as of right now the only counties we know are affected are FL: Lee, Bay, Martin, Manatee, and St. Lucie. The majority of searches are still able to be conducted as these jurisdictions are mostly online, so there shouldn't be many delays. We will notify you of any updates as we receive them.
Posted Sep 28, 2022 - 18:12 UTC