United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] New York Delays
Incident Report for Checkr US Data Status
Resolved
02/18/2021: The New York online portal is back up and running.
Posted Feb 18, 2021 - 16:28 UTC
Identified
ETA: Unknown

02/17/2021: The New York online portal is currently down. They are aware of this and actively working on the issue. As a result, there will be a delay with all reports. We currently do not have an ETA but will monitor this and keep you updated when it is back online.
Posted Feb 17, 2021 - 17:36 UTC