United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Alaska Online System is Down
Incident Report for Checkr US Data Status
Resolved
05/18/2021: Alaska is back online and functioning properly.
Posted May 18, 2021 - 20:27 UTC
Update
05/13/2021: Alaska is still experiencing outages and there is currently no ETA for when this will be back up and running. We will continue to monitor this and send updates.
Posted May 13, 2021 - 18:15 UTC
Monitoring
05/10/2021: Alaska systems are still offline and there is currently no ETA of when it will be back up. Our researchers are in contact with the state and we will continue to monitor this.
Posted May 10, 2021 - 15:05 UTC
Identified
ETA: TBD

05/06/2021: Alaska has experienced outages this week in its entire court system due to a breach, preventing any searches from being completed. Our researchers are in contact with the state and we will continue to monitor this closely.

*This will affect all searches*
Posted May 06, 2021 - 14:48 UTC