Michigan Civil Search Update - DOB Redaction
Incident Report for Checkr Data Status
Resolved
This incident has been resolved.
Posted Apr 22, 2022 - 23:49 UTC
Monitoring
Due to the ongoing DOB redactions in MI, in Charlevoix, Missaukee, and Wexford courts are unwilling to fulfill searches out of the district courts. CIVIL searches in these specific jurisdictions will be completed as circuit-only moving forward. Checkr is continuing work on alleviating the DOB Redaction issue and any updates can be found on this blog post: https://checkr.com/blog/how-date-of-birth-redactions-affect-the-background-check-process.
Posted Jan 24, 2022 - 15:30 UTC