United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Florida DMV Scheduled Maintenance 1/13-1/17
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jan 17, 2023 - 17:30 UTC
Update
As a reminder, the Florida DMV will be performing scheduled maintenance starting today at 4pm PT and ending Tuesday, 1/17 at 4am PT. MVRs ordered during this time will not be available, but will be processed once service is restored.
Posted Jan 13, 2023 - 15:48 UTC
Identified
The Florida DMV will be performing scheduled maintenance starting on Friday, 1/13 at 4pm PT and ending Tuesday, 1/17 at 4am PT. MVRs ordered during this time will not be available. Please note that MVRs will be processed once service is restored.
Posted Jan 10, 2023 - 17:04 UTC