United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Hawaii DMV is Offline
Incident Report for Checkr US Data Status
Resolved
12/1/2021: The Hawaii DMV is back online and orders are able to be processed.
Posted Dec 01, 2021 - 19:11 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 29, 2021 - 22:23 UTC
Investigating
11/29/2021: The Hawaii online DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will update as we learn more.
Posted Nov 29, 2021 - 22:23 UTC