United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Court Closures Due to Hurricane Elsa
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jul 12, 2021 - 19:56 UTC
Identified
07/07/2021: Several county courts across the South are closing due to the tropical storm, including Georgia counties Brantley, Camden, Cook, Glynn, Mcintosh. We anticipate counties will re-open late this week, but we will continue to monitor this as the storm passes.
Posted Jul 07, 2021 - 21:44 UTC