United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] California DMV is Offline
Incident Report for Checkr US Data Status
Resolved
The California online DMV briefly went offline this morning, but is already back up and running. We will alert you if anything changes.
Posted Jul 30, 2021 - 17:55 UTC
Identified
The California online DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will update as we learn more.
Posted Jul 30, 2021 - 17:49 UTC