United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Mississippi DMV Maintenance 4/16
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Apr 19, 2022 - 18:44 UTC
Identified
The Mississippi DMV will be offline from 6am - 3pm Pacific on Saturday, April 16 for scheduled maintenance. MVRs will be unavailable during this time and any requests placed during the maintenance window will be completed once service is restored.
Posted Apr 13, 2022 - 19:52 UTC