United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] North Carolina System Migration
Incident Report for Checkr US Data Status
Update
Update: Extension of System Transition Period

North Carolina is transitioning to a new case management system which started on April 24th. Due to extended updates, the following counties will now be unavailable through May 7th: Alamance, Chatham, Durham, Franklin, Granville, Guilford, Orange, Person, Vance, and Warren. The North Carolina statewide search will also be unavailable during this extended period.
Posted May 03, 2024 - 22:16 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 30, 2024 - 22:22 UTC
Update
Correction to our first notification.

North Carolina is transitioning to a new case management system starting today, April 24th. As a result, certain counties will become unavailable:

- The following counties will be unavailable starting today to Friday, May 3rd: Alamance, Chatham, Durham, Franklin, Granville, Guilford, Orange, Person, Vance, and Warren. The North Carolina statewide search will also be unavailable during this time.

- Additionally, the following counties will be unavailable from Friday, April 26th to Sunday, April 28th: Harnett, Johnston, Lee, Wake, Mecklenburg, Beaufort, Camden, Chowan, Currituck, Dare, Gates, Hyde, Martin, Pasquotank, Perquimans, Tyrrell, and Washington.

We apologize for the confusion.
Posted Apr 24, 2024 - 20:16 UTC
Monitoring
North Carolina is transitioning to a new case management system starting tomorrow, April 24th. As a result, the following counties will be unavailable from Monday, April 29th to Friday, May 3rd: Alamance, Chatham, Durham, Franklin, Granville, Guilford, Orange, Person, Vance, and Warren. The North Carolina statewide search will also be unavailable during this time.

Please note that Checkr will be returning *max available results* from Wednesday, April 24th until the migration begins on Monday, April 29th. We appreciate your patience during this system migration.
Posted Apr 23, 2024 - 18:27 UTC