United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Cyber Attack - Fulton, GA
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted May 02, 2024 - 22:06 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 30, 2024 - 22:22 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 25, 2024 - 17:20 UTC
Update
The Fulton county court staff have confirmed the predominately used index is no longer impacted by the cyber-attack. Please expect continued delays.
Posted Apr 19, 2024 - 21:23 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 11, 2024 - 22:36 UTC
Update
We are continuing to improve processing. Please expect ongoing delays for the next 2-3 weeks.
Posted Apr 05, 2024 - 21:23 UTC
Update
Processing in Fulton, GA is underway. Please expect slowdowns in processing for the next 2 - 3 weeks.
Posted Apr 01, 2024 - 22:36 UTC
Update
Fulton, GA remains inaccessible due to a recent cyberattack. There is no current ETA for restoration. We will continue to monitor the situation.
Posted Feb 08, 2024 - 16:42 UTC
Update
We are continuing to monitor for any further issues.
Posted Feb 06, 2024 - 01:40 UTC
Monitoring
Fulton, GA has suffered a cyberattack which has taken the court's system entirely offline. We are currently unable to process searches. The tentative ETA for restoration is 2/6/24.
Posted Jan 31, 2024 - 20:46 UTC