United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] Massachusetts Court Holiday
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Apr 16, 2024 - 19:48 UTC
Identified
All Massachusetts courts will be closed on Monday, April 15th in observance of Patriots' Day. Please expect a delay on all searches. The courts will reopen on Tuesday, April 16th.
Posted Apr 12, 2024 - 21:29 UTC