United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Weekend DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Apr 15, 2024 - 15:13 UTC
Identified
The following DMVs will be performing scheduled maintenance this weekend during these times:

Utah: Friday, 4/12 from 7pm to Saturday, 4/13 at 7am PT
Idaho: Saturday, 4/13 from 7-11am PT
Maryland: Sunday, 4/14 from 3-8:45am PT
New Jersey: Sunday, 4/14 from 4:30-8am PT

MVRs requested during these times will not be completed until the scheduled maintenance is done.
Posted Apr 12, 2024 - 17:49 UTC